February 6th, 2010

frog

HI EVERYONE!!!!

WOW!

We've had about 30 inches here, though the Dude is saying it's a bit less than that, maybe.

We have a snow blower, but it's been very slow going all day long. I've been shoveling around the house (once he made the first pass) because we kept getting about an inch an hour until late afternoon.

Weatherdude is pleased. A really well-forecasted storm.

We lost power at 10:15pm last night and didn't get it back until just after 4:30pm today. Oh, life in the country! But our neighbors had power so when we were able to connect to their snow-blown path, we sent Miss E over with her dvd player and DS to charge them up. We're almost ready to drive out by the end of today and that's major. I spent a lot of time trying to take the first inches off the snow so the blower would find it easier to do more in the area where we turn our cars around. My car is buried! But we'll work on that tomorrow. The chickens are fine, just cranky with no light in the coop. They don't do white stuff so even though I opened the hatch, I know they won't go outside. I was just trying to add light...if the light gets too low, they stop laying. Can't have that. A slight problem was finding they had very little water, but I melted some snow and now I've filled a can with water to take down there in the morning.

This is just like the storm we had 7 years ago in Feb...except for the losing power part. That time we didn't own anything but shovels and one of our neighbors hired someone with a front-end loader to dig us all out.

And here I am, happy that the power is on so I can brush my teeth and flush my toilet (no well water without electricity, city-slickers). My hair is all over the place from getting snowed on most of the day.